О программе

Navigation: »No topics above this level«

О программе

 Return to chapter overview

Программа GOODS предназначена для автоматизации торговой и складской деятельности. «».

Это универсальное приложение для промышленных терминалов CASIO способно существенно сократить временные затраты на выполнение основных операций с товаром, упростить управление информационными потоками на складах, в розничной торговле, логистике, выездной торговле.

Программа GOODS обеспечивает возможность сбора информации о перемещаемых товарах путём считывания предварительно нанесённых на товар штриховых кодов и сохранение этой информации в виде накладных. А также сбор серийных номеров, подбор заказов и т.д.

Основные возможности программы GOODS:

Инвентаризация, поступление или отгрузка товара.

Формирование заказа.

Оптимизация складских запасов.

Контроль над перемещением и хранением товаров.

Выявление дефицитов продукции.

Сбор сведений о товарах, формирование накладных.

Сбор серийных номеров.

Подбор заказа.

Учёт мест хранения (расстановка товара по местам хранения, подбор заказа по ячейкам).

Печать этикеток, наклеек с помощью мобильного принтера.

Изменения в ПО Goods 4:

1.Нефиксированные форматы файлов обмена.

Все файлы обмена больше не нужно выравнивать по размерам полей. Разделение полей происходит по заданному разделителю (по умолчанию запятая)

2.Количество полей в справочнике товаров увеличено до 30. Дополнительные поля могут быть использованы для Маркировки и Переоценки.

3.Максимальный размер поля – 100 символов.

4.Удалены параметры из настроек:

- максимальная длина штрих-кода (УСТАНОВКИ – ОБЩИЕ – КОД)

- максимальная длина наименования (УСТАНОВКИ – ОБЩИЕ – НАИМ.)

Теперь максимальные длины равны 100 байт.

- позиция точки. Этот параметр теперь относится только к весовому товару и означает разделение целой и дробной части весового товара.

5. Количество может быть дробным до 9 знаков после запятой.

6. Обмен данных с терминалом теперь только текстовый, соответственно удалены параметры ПРИЕМ BIN, ПРИЕМ TXT и т. п. Преобразование форматов происходит в IRServer и терминал получает готовые данные.

7. Протокол обмена остался только HRP, соответственно все старые подставки терминала DT-930 (DT-960, 964) больше не поддерживаются.

8. В стандартную версию добавлен модуль Переоценка,

В Переоценке сравниваются 2 цены из справочника товара (старая и новая). Номер поля цены задается в установках.

Маркировка это отдельный модуль, он активируется отдельно от Переоценки. Шаблоны в этих модулях могут выбираться разными.

9. Добавлено управление установками – загрузка с PC и выгрузка файла установок.

10. Существенно увеличена скорость загрузки и выгрузки данных. По сравнению с загрузкой текстовых данных в 3-ей версии, скорость выросла в несколько раз.

11. Изменены внутренние форматы данных терминала, в дальнейшем планируется выпустить новую версию hrp.dll и 1c_hrp.dll

12. Изменен интерфейс программы, задействован сенсорный экран.

____________

Hexagon: Power solutions.

Инструкция по программному продукту «Goods».

http://www.geksagon.ru

Все права защищены © 2009 Гексагон.


Форматы Goods

Navigation: »No topics above this level«

Форматы Goods

 Return to chapter overview

Формат товарного справочника:

тридцать полей. Первое поле - штрих-код.

Формат имен полей:

одно поле. Первое поле - имя поля.

Формат накладной:

четыре поля - штрих-код, цена, количество, наименование.

Формат мест хранения:

ячейки: одно поле ячейки, без разделителей.

накладные расстановки: поле штрих-кода, поле ячейки, количество.

накладные подбора входящие: поле ячейки, поле штрих-кода, поле необходимого окличества, поле реального количества

накладные подбора исходящие: поле ячейки, поле штрих-кода, поле необходимого окличества, поле реального количества

Формат подбора заказа:

три поля - Шк, необходимое количество, реальное количество.

Формат серийных номеров:

три поля - Артикул, серийный номер, количество

Файлы накладных хранятся в определенных каталогах GOODS-а:

товарный справочник:

С:\GOODS\GOODS\goods.txt – товарный справочник.

имена полей:

С:\GOODS\GOODS\goods_f.txt – имена полей.

накладные:

С:\GOODS\ORDER\*.txt – накладные.

С:\GOODS\ORDER\INVENT.txt – накладная инвентаризации при включенной опции «совместимость».

места хранения

С:\GOODS\PLACE\place.txt - список ячеек

С:\GOODS\PLACE\INPUT\*.txt – накладные расстановки

С:\GOODS\PLACE\PODBOR\IN\*.txt – накладные подбора входящие

С:\GOODS\PLACE\PODBOR\OUT\*.txt – накладные подбора исходящие

места заказов

С:\GOODS\PODBOR\IN\*.txt – файлы заказа входящие

С:\GOODS\PODBOR\OUT\*.txt – файлы заказа исходящие

места серийных номеров

С:\GOODS\serial\*.txt – файлы серийных номеров.

места маркировки и перемаркировки

С:\GOODS\LABEL\*.lbl – файлы шаблонов.


Goods

Navigation: »No topics above this level«

Goods

 Return to chapter overview

Полное описание всех функций программы.

Скриншоты могут отличаться, надписи в меню могут быть сокращены (зависит от модели терминала).

В терминалах с сенсорным экраном, для совершения операций, можно нажимать стилусом на соответствующие пункты меню.


Стандартное меню Goods

Navigation: Goods >

Стандартное меню Goods

 Return to chapter overview

Меню программы гудс, в стандартной сборке (без модулей) может отличаться в зависимостки от установленной версии:

Reader:

Версия Ридер - простой сборщик ШК в список построчно с возможностью выгрузить файл списка через ик порт или usb подставку.

Lite:

Лайт версия позволяет создать одну накладную, в которой указывается штрих код, количество, и можно через дополнительное меню назначить цену.

Base:

Базовая версия - работа с товарным справочником, и возможность создать до трех накладных. Ограничения товарного справочника десять тысяч строк. Более десяти тысяч не будут отображаться.

Prof:

Профессиональная версия - версия без ограничение на размер справочника, создания разных накладных. Абсолютно все настройки программы доступны для пользователя.

Absolute:

Профессиональная версия со всеми включенными в нее модулями.


Накладные

Navigation: Goods >

Накладные

Учет движения материальных ценностей внутри организации и для инвентаризации.

 Return to chapter overview

Меню содержит перечень наименований документов с возможностью редактировать, удалять и формировать новые.

Каждому новому документу может быть присвоено имя. Например, в виде даты создания документа, по номеру склада, где проводилась инвентаризация, и т.д.

3.1.1Создание накладной

Перед началом работы необходимо создать накладную.

Для создания накладной, в меню НАКЛАДНЫЕ при помощи цифровой клавиатуры выберите пункт 1. Создать новую и нажмите ENT.

Введите имя накладной – имя может быть любым (Вводимое имя должно быть длинной до 8 символов). Либо на латинице, либо каким-то числом. Нажмите ENT.

3.1.2 Работа с накладной (Режим нового ввода выключен)

Пункт меню “Ввод”

В режиме ввода код товара вводится в накладную с клавиатуры или считывается сканером, после чего можно вручную ввести необходимое количество. В обычном режиме удобно вводить данные, когда количество товара одного типа велико, и проще ввести его вручную. Так же, в этом режиме, можно изменять данные накладной, для этого выберите нужный товар и нажмите клавишу f4. Появится дополнительное меню «Операции» где можно изменить цену товара, его количество и удалить товар.

Пункт меню “Циклический ввод”

В режиме циклического ввода количество товаров с одинаковым штрих кодом увеличивается автоматически. Если товар есть в товарном справочнике, то на экране отобразится его цена и наименование. В этом режиме удобно вводить данные, когда количество товаров одного типа невелико, либо требуется ввод каждой единицы товара (для проверки). Так же, в этом режиме, можно изменять данные накладной, для этого выберите нужный товар и нажмите клавишу f4. Появится дополнительное меню «Операции» где можно изменить цену товара, его количество и удалить товар.

Пункт меню “Просмотр”

Просмотр введенной в терминал информации о собранном товаре и его количестве. Если товаров больше десятка, то для быстрого его поиска, можно отсканировать товар. Так же, в этом режиме, можно изменять данные накладной, для этого выберите нужный товар и нажмите клавишу f4. Появится дополнительное меню «Операции» где можно изменить цену товара, его количество и удалить товар.

Пункт меню “Итоги”

Это меню подводит итоги о созданной накладной – количество записей, количество товара и его суммарная стоимость.

Пункт меню “Передача”

При выборе этого пункта происходит передача накладной на компьютер в папку программы, через выбранный порт.

Пункт меню “Очистка”

При выборе этого меню происходит удаление всех записей накладной, при этом сама накладная остается.

Пункт меню “Удаление”

Полное удаление накладной из памяти терминала.

Работа с накладной (Режим нового ввода включен)

Пункт меню “Ввод”

Режим нового ввода заменяет три операции: ввод, циклический ввод и просмотр.

Меню открывается через клавишу F4-Меню (по умолчанию, запрос количества, запрос цены заполнены из установок).

При открытии карточки меню накладной напоминает меню простого ввода, с отсутствующим полем Просмотр.

При сканировании ШК, терминал будет увеличивать количество одинаковых товаров на еденицу. (при установленном флаге "запрос количества" введенное количество будет прибавляться к текущему)


инвентаризация

Navigation: Goods > Накладные >

инвентаризация

 Return to chapter overview

При активации опции «совместимость» в меню накладных появится новый пункт: инвентаризация:

Принцип работы такой же, как и в работе с накладными:

Пункт меню “Ввод”

В режиме ввода код товара вводится в накладную с клавиатуры или считывается сканером, после чего можно вручную ввести необходимое количество. В обычном режиме удобно вводить данные, когда количество товара одного типа велико, и проще ввести его вручную. Так же, в этом режиме, можно изменять данные накладной, для этого выберите нужный товар и нажмите клавишу f4. Появится дополнительное меню «Операции» где можно изменить цену товара, его количество и удалить товар.

Пункт меню “Циклический ввод”

В режиме циклического ввода количество товаров с одинаковым штрих кодом увеличивается автоматически. Если товар есть в товарном справочнике, то на экране отобразится его цена и наименование. В этом режиме удобно вводить данные, когда количество товаров одного типа невелико, либо требуется ввод каждой единицы товара (для проверки). Так же, в этом режиме, можно изменять данные накладной, для этого выберите нужный товар и нажмите клавишу f4. Появится дополнительное меню «Операции» где можно изменить цену товара, его количество и удалить товар.

Пункт меню “Просмотр”

Просмотр введенной в терминал информации о собранном товаре и его количестве. Если товаров больше десятка, то для быстрого его поиска, можно отсканировать товар. Так же, в этом режиме, можно изменять данные накладной, для этого выберите нужный товар и нажмите клавишу f4. Появится дополнительное меню «Операции» где можно изменить цену товара, его количество и удалить товар.

Пункт меню “Итоги”

Это меню подводит итоги о созданной накладной – количество записей, количество товара и его суммарная стоимость.

Пункт меню “Передача”

При выборе этого пункта происходит передача накладной INVENT.txt на компьютер в папку программы, через выбранный порт.

Пункт меню “Очистка”

При выборе этого меню происходит удаление всех записей накладной, при этом сама накладная остается.


Товарный справочник

Navigation: Goods >

Товарный справочник

 Return to chapter overview

Пункт меню “Просмотр” (товарного справочника)

Товар можно просматривать кнопками «F2» и «F3», Так же можно найти товар при помощи сканирования штрих кода. Если этот товар присутствует в базе, то будет указано его наименование и цена.

Пункт меню “Прием”

При выборе данного пункта производиться прием файла товарного справочника с компьютера.

Пункт меню “Удаление”

Удаление товарного справочника с терминала.


Карточка товара

Navigation: Goods >

Карточка товара

 Return to chapter overview

Карточка товара, вызывается из любого режима ввода (тов. спр, накладные, подбор итд.) через клавишу F4-Меню.

В карточке Можно посмотреть все поля ТС. Переход осуществляется клавишами стрелок врпаво и влево.


Модули Goods

Navigation: Goods >

Модули Goods

 Return to chapter overview

Модули ставятся на любые версии GOODS, начиная с light. Ограничения версий ведут за собой ограничение модулей, например - невозможность работать с товарным справочником, передача данных толкьо через ик.


Серийные номера

Navigation: Goods > Модули Goods >

Серийные номера

 Return to chapter overview

Серийные номера.

Для начала работы необходимо создать файл: пункт меню Серийные номера – создать.

Файл можно создать при помощи цифровой клавиатуры, выбрав пункт «Создать» и нажав «ENT».

Далее, введите имя файла – имя может быть любым. Либо на латинице, либо каким-то числом нажмите «ENT».

Пункт меню “Ввод”

Вводится артикул товара – либо на клавиатуре, либо путем считывание штрих кода. Нажмите ENT, после чего можно сканировать серийные номера и они будут добавляться в базу с этим артикулом.

Если вам нужно добавить другое наименование товара, то нажмите CLR и введите код товара, после чего можно добавлять его серийные номера.

Пункт меню “Просмотр”

Просмотр созданной базы серийных номеров.

Показывается наименование товара, его серийный номер и количество.

Как и с накладной в этом режиме есть возможность редактировать данные путем выбора нужного наименования и нажатия клавиши F4 появится меню «Операции» где можно менять наименование товара, его серийный номер, количество, либо удалить товар из списка.

Пункт меню “Передача”

При выборе этого пункта меню нажатии клавиши 3 происходит передача накладной на компьютер в папку программы.

Пункт меню “Очистка”

При выборе данного пункта, происходит удаление всех записей базы, при этом сам файл остается в памяти.

Пункт меню “Удаление”

При выборе данного пункта меню, происходит полное удаление базы серийных номеров из памяти терминала.


Подбор заказов

Navigation: Goods > Модули Goods >

Подбор заказов

 Return to chapter overview

Заказ формируется на PC. В заказ входит код товара и необходимое кол-во. Также резервируется поле под реальное кол-во, которое заполняется на терминале. На терминале заполняется реальное кол-во (в обычном или циклическом режиме ввода).

Заказ может быть сортированный по коду и несортированный. Если сортировка есть, то поиск в заказе товара осуществляется быстрее. Добавление товара в заказ на терминале и удаление товара возможно только в несортированный заказ. За вид заказа отвечает ключ в установках сортировка.

Для начала работы необходимо создать заказ в меню «Создать». Вводится название заказа (такое же, как и имя файла заказа на компьютере), после чего выбираете в меню пункт «Прием». Файл заказа должен находиться в папке C:\GOODS\PODBOR\IN.

3.4.2 Работа с заказом.

Пункт меню “Ввод”

В режиме ввода необходимо ввести код товара с клавиатуры либо считыванием штрих кода. Так же можно менять количество товара вручную, нажатием клавиши «F4»

Пункт меню “Циклический ввод”

В режиме циклического ввода количество наименования считывается автоматически. При попытке набора большего количества товара, чем в базе данных заказа, происходит звуковой сигнал и предупреждение о набранном лимите (это зависит от установок в настройках). Вы можете либо добавить количество товара в базу, либо не изменять. Так же можно менять количество товара вручную, нажатием клавиши «F4».

Пункт меню “Просмотр”

В режиме просмотра вы можете просматривать загруженную базу заказа, количество необходимого товара и их реальное количество .При нажатии F4 можно менять количество реально собранного заказа.

Пункт меню “Просмотр несоответствия”

Режим показывает только те наименования, чье количество реально собранного товара не совпадает с тем, что указано в заказе

Пункт меню “Итоги”

Показывает итоговые данные заказа: Количество записей, сумма количества товара заказа, сумма количества реально собранного заказа, и количество несоответствия товара (те товары, которые не были собраны полностью)

Пункт меню “Передача”

Передача файла на компьютер

Пункт меню “Прием”

Прием заказа с компьютера .

Пункт меню “Очистка полная”

Полная очистка всех записей файла заказа.

Пункт меню “Очистка ввода”

Удаление только введенных данных со сканера терминала либо с клавиатуры.

Пункт меню “Удаление”

Удаление заказа из памяти терминала.


Места хранения

Navigation: Goods > Модули Goods >

Места хранения

 Return to chapter overview

Места хранения.

Позволяет работать с товаром, который рассортирован по местам хранения. Каждое место хранения или ячейка, должно быть промаркировано при помощи штрихкода.

Файлы накладных хранятся в определенных каталогах GOODS-а:

С:\GOODS\PLACE\place.txt - таблица ячеек

С:\GOODS\PLACE\INPUT\*.txt – накладные расстановки

С:\GOODS\PLACE\PODBOR\IN\*.txt – накладные подбора входящие

С:\GOODS\PLACE\PODBOR\OUT\*.txt – накладные подбора исходящие

Главное меню:

Пункт меню “Расстановка”.

Расстановка товара в ячейки

Для начала работы создается накладная расстановки (меню 1. Создать).

Пункт меню “Ввод”.

В режиме ввода вносятся ячейки и товар, находящийся в ячейках. Сначала сканером считывается код ячейки, или вводится с клавиатуры, затем вводится штрих код товара лежащего в этой ячейке и подсчитывается количество. \

Пункт меню “Просмотр”

Показывается штрих код товара, ячейка и количество.

При нажатии F4 появляется дополнительно меню «операции» где можно изменить ячейку, количество товара, или удалить товар из ячейки.

Пункт меню “Передача”

Передача файла созданной накладной расстановки на компьютер.

Пункт меню “Очистка”

Удаление введенных данных с созданной накладной

Пункт меню “Удаление”

Удаление накладной расстановки

Пункт меню “Подбор”

Показывает количество подобранного товара и необходимое количество.

Для работы с подбором заказа по ячейкам нужно предварительно загрузить накладную на подбор, сформированную на PC. Все накладные, подготовленные на ПК, грузятся одновременно.

Пункт меню “Прием”

Принимает все накладные подбора заказа с компьютера

Пункт меню “Передать все”

Передает все накладные подбора заказа на компьютер.

Пункт меню “Удалить все”

Удаляет все накладные подбора с терминала.

При приеме файла появится новое меню с наименованием файла подбора заказа.

Созданная накладная

Пункт меню “Ввод” – необходимо считать штрих код ячейки либо ввести с клавиатуры, считывается код ячейки и редактируется количество товара. После ввода количества и нажатия на клавишу ENT в меню появится следюющий штрих код товара, лежащего в этой ячейке и находящегося в накладной заказа.

Пункт меню “Просмотр” – Показывается штрих код товара, ячейка и количество. Если количество не совпадает с заданным, то это поле выделяется полосой.

Пункт меню “Передача” – передача накладной на ПК

Пункт меню “Очистка” – очистка накладной от введенных значений

Пункт меню “Удаление” – удаление накладной с ПК

Пункт меню “Прием ячеек” – прием БД ячеек с компьютера.


Маркировка

Navigation: Goods > Модули Goods >

Маркировка

 Return to chapter overview

Маркировка.

Этот режим работы позволяет печатать этикетки на мобильном принтере, подключённом к терминалу через Bluetooth-соединение. Этикетка печатается по определённому шаблону, который должен быть предварительно загружен в терминал. Таким образом, можно оперативно производить маркировку товара.

Начало работы:

Для начала нужно выбрать шаблон этикетки для маркировки. Для этого в меню Маркировка выберите пункт выбор шаблона. На экране появится список доступных шаблонов. Выберите нужный шаблон из списка.

Затем выберите меню ввод и печать.

Если макет шаблона позволяет добавлять или изменять информацию, то кроме вывода в принтер, появится возможность редактировать изменяемые поля макета этикетки.

Список шаблонов загружается на терминал в меню установки -> маркировка


Переоценка

Navigation: Goods > Модули Goods >

Переоценка

 Return to chapter overview

Переоценка.

Этот режим работы позволяет печатать этикетки на мобильном принтере, подключённом к терминалу через Bluetooth-соединение. Этикетка печатается по определённому шаблону с использованием разницы цен в справочнике, шаблон должен быть предварительно загружен в терминал. Таким образом, можно оперативно производить переоценку товара. Переоценка бывает непрерывной и одиночной.

Начало работы:

Для начала нужно выбрать шаблон этикетки для маркировки. Для этого в меню Маркировка выберите пункт выбор шаблона. На экране появится список доступных шаблонов. Выберите нужный шаблон из списка.

Непрерывная – Режим переоценки, при котором после сканирования штрих кода товара, который необходимо переоценить, сразу же следует печать на мобильном принтере.

При нахождении товара без измененной цены появится предупреждение – «Ошибка Цены одинаковые».

Если товар отсутствует в БД, то появится надпись об отсутствующем товаре в БД.

Однократная – Режим переоценки, при котором после сканирования штрих кода выдается запрос – печатать этот товар или нет, при этом не происходит сравнивания полей старой и новой цены.

Журнал – Режим просмотра пероцененных товаров. Список товаров выгружается в компьютер в виде накладной.


Установки

Navigation: Goods >

Установки

 Return to chapter overview

Настройки программы гудс. Некоторые пункты могут отсутствовать или иметь неполный функционал, в зависимости от версии.


Конфигурация

Navigation: Goods > Установки >

Конфигурация

 Return to chapter overview

В настройках конфигурации можно убрать "ненужные" пункты из главного меню программы:


Товарный справочник

Navigation: Goods > Установки >

Товарный справочник

 Return to chapter overview

Настройки товарного справочника.

1. диск – место хранение товарного справочника – ram или flash память.

2. кодировка – используемая кодировка.

3. сортировка – будет ли сортироваться товар или нет. Для более быстрого поиска необходимого наименования сортировка должна быть включена.

4. Удалять справочник на PC – после загрузки товарного справочника на ТСД, он удаляется из папки goods на PC.

5. Прием имен полей – загружает файл с именами полей для карточки товара.

6. N цены – номер столбца товарного справончика, в котором находится информация о цене.

7. N наимен. – номер столбца товарного справончика, в котором находится информация о наименовании.


Накладные

Navigation: Goods > Установки >

Накладные

 Return to chapter overview

Настройки накладной:

1. Искать товар. – Ввести или нет поиск товара в справочнике. Если поиск не включен, то товар отображается без наименования и с пустой ценой

2. Искать в накладной. – при включении режима ведется поиск в накладной. Если товар там найден, то отображается его количество, а в циклическом режиме прибавляется единица.

3. Товар не из БД. – Включенный режим позволяет вводить товар, отсутствующий в базе данных товарного справочника.

4. Добавлять кол-во – при включенном режиме введенное количество товара добавляется к существующему количеству в режиме обычного ввода.

5. Ручной ввод – при включенном режиме появляется ввести код товара с клавиатуры терминала.

6. Ввод цены. - При включенном режиме можно вводить цену товара при сканировании товара в режиме ввода. (При сканировании появляется поле для ввода цены).

7. Групповые операции – Работа с группами накладных и заказов. В этом режиме в списке накладных и заказов появляется меню «передать все», «удалить все».

8.Передача цены. – При передаче накладной в тхт позволяет передавать колонку цены. Только код и количество.

9. Передача наименования. – при передаче накладной в тхт, позволяет передавать колонку «наименование».

10. Дублирующие коды. – Если в товарном справочнике присутствует наименование %новый код%, то при включении этого режима старый код товара заменяется новым.

пример:

100016,55.00,ТОРТ МЕДОВИК ХАЛВА 4

100017,55.00,ТОРТ МЕДОВИК ЦУКАТЫ

123321,0,%100016%

при считывании кода 123321, в накладную добавится товар "торт медовик халва"

11. Совместимость – включение меню «инвентаризация».

12. Запрет префикса – Позволяет запретить ввод кодов, которые начинаются на префикс.

13. Режим нового ввода – выключает режим нового ввода в накладной.

14. Запрос количества – Позволяет запрашивать количество отсканированного штрих-кода.

14. Запрос цены – Позволяет запрашивать цену отсканированного штрих-кода.


Серийные номера

Navigation: Goods > Установки >

Серийные номера

 Return to chapter overview

Настройки серийных номеров:

1. Искать номер. – При активации этой функции производится автоматический поиск номера в существующем списке серийных номеров. Вводить номер повторно уже нельзя.

2. Ввод кол-ва – При включении этой функции можно вводить количество с/н.


Подбор заказа

Navigation: Goods > Установки >

Подбор заказа

 Return to chapter overview

Настройки Заказов

1. Искать товар в БД. – Ввести или нет поиск товара в справочнике. Если поиск не включен, то товар отображается без наименования и с пустой ценой.

2. Добавлять количество. – Добавлять или нет количество товара. При включенном режиме введенное количество товара добавляется к существующему количеству.

3. сортировка – будет ли сортироваться товар или нет. Для более быстрого поиска необходимого наименования сортировка должна быть включена.

4. Добавление – при включении этого режима можно добавлять товар в заказ с терминала.

5. Групповые операции – Работа с группами накладных и заказов. В этом режиме в списке накладных и заказов появляется меню «передать все», «удалить все».

6. Дублирующие коды. – Если в товарном справочнике присутствует наименование %новый код%, то при включении этого режима старый код товара заменяется новым.


Места хранения

Navigation: Goods > Установки >

Места хранения

 Return to chapter overview

Настройки мест:

1. Искать ячейку. – Искать или нет код ячейки в справочнике ячеек.

2. Искать товар. – Искать или нет код товара в справочнике товаров.

3. Товар не из БД. – Вводить или нет товар, которого нет в справочнике товаров.

4. Искать в накладной. – искать или нет код товара в пределах ячейки.


Маркировка

Navigation: Goods > Установки >

Маркировка

 Return to chapter overview

Настройка маркировки:

1. Интерфейс - выбор типа соединения с принтеорм (bluetooth или сетевой), настройка принтера.

2. Загрузка шаблонов - загрузка шаблонов с пк на терминал, удаление ненужных шаблонов.


Переоценка

Navigation: Goods > Установки >

Переоценка

 Return to chapter overview

Настройки переоценки:

1. Интерфейс - выбор типа соединения с принтеорм (bluetooth или сетевой), настройка принтера.

2. Загрузка шаблонов - загрузка шаблонов с пк на терминал, удаление ненужных шаблонов.

3. N Старой цены - номер поля товарного справочника со старой ценой товара.


Весовой товар

Navigation: Goods > Установки >

Весовой товар

 Return to chapter overview

Настройки весового штрих-кода:

Позволяет обрабатывать товар, подготовленный на электронных весах. Количество товара будет учитываться в весовых единицах.

Разбор весового товара:

AABBBBBCCCCCD размер кода – 13 символов (тип штрих-кода EAN13)

AA – префикс весового товара. По нему программа определяет, что товар

весовой и обрабатывает его.

BBBBB – код весового товара.

ССССС – вес в граммах

D – контрольный знак

1. Разрешить вес – учитывать или не учитывать весовой товар.

2. Учитывать префикс. – при включении будет учитываться префикс в составлении кода. Код – длина кода товара.

3. Позиция точки – позиция точки веса, устанавливает количество знаков с конца после точки, в дробных числах для веса (CCCCC)

4. Диапазон 20 – 29. – ввод диапазона префикса.

Рекомендуется при включении весового товара выставить:

- флаг добавления количества в [+] (для добавления) (настройка накладной)

- позицию точки в 3 (для учета в граммах)


Общие

Navigation: Goods > Установки >

Общие

 Return to chapter overview

Общие настройки программы Goods:

1. Смена пароля – устанавливает пароль на вход в меню «установки».

2. Номер – номер терминала. По умолчанию 0. используется, если в производстве используется сразу несколько терминалов.

3. Порт – настройки порта соединения терминала с ПК:

==================================

Тип - тип порта: ИК порт, Bluetooth, Сеть, Active Sync.

(в версии DT-930 присутствует только IRDA и bluetooth)

Порт - номер порта подключения

При выборе типа связи Сеть появится пункт - Сервер, для ввода IP сервера.

При выборе типа связи Bluetooth появится пункт Настройка – пункт появляется при выборе Bluetooth-а. Сканирует ближайшие Bluetooth устройства, и в появившемся списке выбора необходимо выбрать

необходимый ПК с включенным Bluetooth и отключенными параметрами шифрования.

Таймаут - установка таймаута подключения.

==================================

4. Режим сервера – необходим для работы преедачи данных напрямую с программным обеспечением через библиотеки. (используется в 1с)

5. Разрешить выход – при включении этого меню, в главном меню программы появится новый пункт: «выход», при выборе которого можно выйти из программы.

6. Сигнал ошибки – установки сигнала, который звучит при ошибке.

==================================

Разрешить - включение сигнала ошибки

Частота – частота сигнала ошибки.

Длительность – длительность сигнала.

Вибрация – включение вибрации при ошибке.

Индикация – включение световой индикации при ошибке.

Тест – тест сигнала.

==================================

7. Диск PC – выбор директории на компьютере, где создана папка goods.

8. Режим сохранения. – при включении этого режима, при каждой записи информации в файл каждый раз идет сохранение файла.

9. Запрет пользователя. – Запретить пользователю. При включении этого меню отключаются некоторые пункты меню.

В накладных пропадают меню связанные с их созданием, удалением, передачей на ПК.

10. Клиенты. – пользовательские настройки.


Штрих-код

Navigation: Goods > Установки >

Штрих-код

 Return to chapter overview

Установки штрих-кода:

1. Дополнить нулями – при включении режима, дополняет код товара, до максимальной длины кода (сто символов).

2. По умолчанию – сброс настроек штрих кодов по умолчанию.


Управление

Navigation: Goods > Установки >

Управление

 Return to chapter overview

Управление установками терминала:

1. Передача – передача файла настроек на ПК.

2. Прием – прием файла настроек с ПК.

3. Изменить версию – изменение версии программы.

4. Сброс – сброс настроек программы


Общие настройки

Navigation: »No topics above this level«

Общие настройки

 Return to chapter overview

Установка, активация, обновление, настройки передачи данных,

создание и установка шрифтов, создание и установка шаблонов этикеток.


dt-930

Navigation: Общие настройки > Установка Goods >

dt-930

 Return to chapter overview

Установка программы на терминал casio DT-930 (необходима программа LMWin32):

dыберите вкладку configure и поставьте галочку в пункте - B.B/S.B(IOBOX)

после чего выбираете вкладку execute -> command.

в новом окне - command - выбираем send

files - жмем browse и выбираем файлы, необходимые для установки по одному.

После того, как выбрали все нужные файлы, в окошке destination dir пишем строку вида: B:

жмем ок и сворачиваем программу.

на терминале:

Если на терминале установлен сторонний софт, то необходимо выйти из него в операционную систему терминала. При невозможности выхода, нужно нажать reset сзади терминала.

Выбираем пункт 4.transmitе -> 4 utilite -> 2. format drive -> форматируем диск А и В

настройка терминала к приему программы:

в главном меню снова 4 transmite -> port -> 2 fir - нажимает ent. Жмем 4. utilite -> 1 trans file.

и кладем ик портом терминала к ик порту компьютера.

если все удачно, то у вас появится предыдущее меню. (программа может загружаться от 20 секунд до 2-3 минут.)

выходим в главное меню (два раза нажать clr) далее жмем 1. execute ap, на вопрос отвечаем положительно - ent

жмем "Запуск", Goods v4


windows терминалы

Navigation: Общие настройки > Установка Goods >

windows терминалы

 Return to chapter overview

Установка на windows терминалы:

Для корректной работы на ПК должен быть установлена программа синхронизации Active Sync, или Mobile Device Center. После синхронизации с ПК, необходимо открыть папку мобильного устройства через "Мой компьютер", и положить файлы программы гудс в папку FLASH.


Активация

Navigation: Общие настройки > Обновление и активация GOODS >

Активация

 Return to chapter overview

При первом запуске программы может появится следующее окно:

При выборе режима Автомат, терминал автоматически попытается соедениться с сервером активации: 131

При выборе режима Вручную, отобразится активационный код и поле ввода ключа:

Ключ вводится посредством сканирования сканером терминала специального штрих-кода.

После успешной активации появится окно успешной активации, и настройки программы сбросятся "по умолчанию". 132


Обновление

Navigation: Общие настройки > Обновление и активация GOODS >

Обновление

 Return to chapter overview

Для обновления программы (добавление модуля, или получения более "старшей" версии)

необходимо войти в «управление» и выбрать пункт «Изменить версию».

При выборе режима Автомат, терминал автоматически попытается соедениться с сервером активации: 131

При выборе режима Вручную, отобразится активационный код и поле ввода ключа:

Ключ вводится посредством сканирования сканером терминала специального штрих-кода.

При выборе пункта «Файл» откроется новое меню:

Передать - на ПК передается файл с активационным кодом.

Принять - с ПК загружается файл активации и автоматически обновляется версия.


IR Server

Navigation: Общие настройки >

IR Server

 Return to chapter overview

IR-Server - программа для связи терминала с ПК:

Старт - запуск программы

Стоп - остановка программы

Выход - выход зи программы.

Усттановки - открывает окно с настройками программы:

При работе через IRDA порт (все терминалы), или USB подставку - терминалы DT-930, x-11 - необходимо выбрать "ИК-порт". (галочка "Режим IRComm" ставится при работе с терминалом DT-930)

При работе через WI-Fi (все терминалы с WiFi), или USB подставку - терминалы DT-X7, IT-600 - необходимо выбрать "Сеть" и порт (по умолчанию 2000).

ПРи работе через bluetooth (все терминалы) необходимо выбрать "СОМ порт" и в ниспадающем меню выбрать номер порта, соответствующий порту bluetooth устройства. (галочка "DT-930 bluetooth" ставится при работе с терминалом DT-930)

=====================================================================

В «Товарном справочнике» используются разделители полей. В настройках программы необходимо настроить используемый разделитель в справочнике, посредством ввода в поле «Разделитель в таблицах ASCII код» его код. в окошке будет отображаться выбранный знак разделителя:


Шаблоны и шрифты

Navigation: Общие настройки >

Шаблоны и шрифты

 Return to chapter overview


Шрифты

Navigation: Общие настройки > Шаблоны и шрифты >

Шрифты

 Return to chapter overview

Мобильное Решение

Настройка принтера:

Для корректной работы принтера с русскими шрифтами необходимо их создать и «залить» на принтер.

Создание шрифта:

Зайдите в панель управления и выберите Принтеры и факсы.

Нажмите на значке принтера Zebra QL320+. правой клавишй мыши и выберите свойства:

Откроется окно свойств принтера

Для сохранения шрифта на жесткий диск откройте вкладку Порты и выберите порт File:

В окне выберите вкладку Printer, выделите Printer font Options и нажмите Settings:

Откроется окно загруженных шрифтов:

В левой части список всех загруженных шрифтов, в правой их настройки и описание.

Нажмите Download font…

Откроется основное окно создания шрифта:

Выберите необходимый шрифт и его настройки.

Обязательно поставьте чекбокс – Extended

После нажатия Font Download появитсяокно сохраниния файла:

Обязательно укажите полный путь файла, с его названием и расширением «.cpf»

После чего можно закрыть все окна, или создать новый шрифт.

Редактирование шрифта:

Для редактирования шрифта желательно воспользоваться FAR-ом.

Блокнотом тоже можно открыть, но будьте осторожны, не меняйте структуру файла.

Открываем файл и меняем вторую и 7 строчки – (ID шрифта) на ID от 90 до 100:

Сохраняем изменения и закрываем файл.

Подключаем принтер к COM порту компьютера, через прилагающийся кабель и включаем его.

Открываем программу Label Vista, выбираем в ниспадающем меню Printer а Com port Setup

И настраиваем порт так же, как и настроем принтер:

выбираем в ниспадающем меню Printer а Send Font

и загружаем шрифты в принтер.

После создания и загрузки шрифтов, не забудьте вернуть порт драйвера принтера на стандартный

(com)

Принтер необходимо отсоединить от кабеля и выключить.

Если для Label Vista установлена программа - font install, то шрифт создается через меню - FONT-NEW

В окне выбирается необходимый шрифт, размер, и кодировка (кириллическая):

! Обязательно указывайте диапазон значений (character range) от 32 до 255

После нажатия на ОК появляется меню сохранения файла шрифта:

в коде этикетки указываете имя файла - например:

T 2 1 254 69 <<<GOODS_ATTRIBUTE_002>>> // текстовые поля – добавим например цену

T 2 1 219 221 <<<GOODS_ATTRIBUTE_003>>> // текстовые поля – к примеру наименование

T 7 0 85 132 <<<GOODS_ATTRIBUTE_001>>> // код под штрих кодом

FORM

PRINT

В строках

T 2 1 254 69

T 2 1 219 221

T 7 0 85 132

Меняем значение шрифта, на тот ID, который вы назначили при создании шрифта:

T ARI08PT.CPF 0 254 69

T ARI08PT.CPF 0 219 221

T ARI08PT.CPF 0 85 132


Макеты

Navigation: Общие настройки > Шаблоны и шрифты >

Макеты

 Return to chapter overview

Работа с Этикеткой: Оптимальная программа для создания этикетки – Label View или Bar Tender

В настройках принтера установите драйвер принтера QL320Plus и создайте макет:

После создания этикетки выбираем Печать (значок Принтера на панели инструментов)

ставим галочку – Печать в файл.

В поле вводим путь и имя файла с расширением .lbl

(LBL)

Открываем полученный файл FAR-ом или блокнотом:

! UTILITIES

GAP-SENSE

SET-TOF 0

IN-DOTS

LEFT

TONE 10

SPEED 5

ON-FEED FEED

TIMEOUT 0

PRINT

! 0 200 200 318 1

LABEL

PAGE-WIDTH 463

BT OFF

B 128 1 0 101 55 22 12345678

SETMAG 0 0

T 2 1 254 69 1234567

T 2 1 219 221 123456789

T 7 0 85 132 12345678

FORM

PRINT

Программа GOODS по умолчанию работает с тремя полями:

Штрих-код (аттрибут <<<GOODS_ATTRIBUTE_001>>>)

Цена (атрибут <<<GOODS_ATTRIBUTE_002>>> )

Наименование (атрибут <<<GOODS_ATTRIBUTE_003>>> )

Меняем необходимые поля, на нужные атрибуты:

(под // написаны комментарии, их не надо вводить в этикетку)

! UTILITIES

GAP-SENSE

SET-TOF 0

IN-DOTS

LEFT

TONE 10

SPEED 5

ON-FEED FEED

TIMEOUT 0

PRINT

! 0 200 200 318 1

LABEL

PAGE-WIDTH 463

BT OFF

B 128 1 0 101 55 22 <<<GOODS_ATTRIBUTE_001>>> // штрих код (в данном случае code 128)

SETMAG 0 0

T 2 1 254 69 <<<GOODS_ATTRIBUTE_002>>> // текстовые поля – добавим например цену

T 2 1 219 221 <<<GOODS_ATTRIBUTE_003>>> // текстовые поля – к примеру наименование

T 7 0 85 132 <<<GOODS_ATTRIBUTE_001>>> // код под штрих кодом

FORM

PRINT

В строках

T 2 1 254 69

T 2 1 219 221

T 7 0 85 132

Меняем значение шрифта, на тот ID, который вы назначили при создании шрифта:

T 92 1 254 69

T 92 1 219 221

T 92 0 85 132

или

T ARI08PT.CPF 0 254 69

T ARI08PT.CPF 0 219 221

T ARI08PT.CPF 0 85 132

Сохраните и закройте файл.

Для загрузки файла, его необходимо поместить в папку C:\GOODS\LABEL\.

При работе с Bar Tender-ом полученный код этикетки будет отличаться:

! U1 setvar "media.type" "label"

! U1 setvar "media.sense_mode" "gap"

! 134 203 203 200 1

COUNTRY LATIN1

SETMAG 1 1

T180 4 0 170 96 Наименование:

T180 4 0 200 30 Цена: <<<GOODS_ATTRIBUTE_002>>>

BT OFF

B 128 1 20 45 310 122 <<<GOODS_ATTRIBUTE_001>>>

T180 4 0 180 122 <<<GOODS_ATTRIBUTE_001>>>

T180 4 0 233 70 <<<GOODS_ATTRIBUTE_003>>>

FORM

PRINT

Меняем значение шрифта, на тот ID, который вы назначили при создании шрифта:

T180 92 0 180 122

T180 92 0 233 70

или

T180 ARI08PT.CPF 0 180 122

T180 ARI08PT.CPF 0 233 70


Настройка работы с 1С

Navigation: »No topics above this level«

Настройка работы с 1С

 Return to chapter overview

Описание установки и настройки обработки для конфигурации УТП 10.3.5.2 1С - 8.1

Примечание:

Конфигурация и обработка ставились на «чистый» 1с, конфигурация стандартная, запуск производился в демо-режиме.

1. Запускаем установку из папки с конфигурацией УТП и устанавливаем всё по умолчанию.

2. Запускаем инсталлятор обработки для терминала – путь установки по умолчанию, все настройки по умолчанию.

3. Запускаем 1с 8-1 выбираем УТ (демо)

4. Заходим в «сервис», «пользователи группы», «группы торг оборудования» и добавляем пользователя в группу «терминалы сбора данных».

5. Заходим в «Сервис» , «Торговое оборудование» , «Подключение и настройка торгового оборудования» :

6. Выбираем вкладку «Терминалы сбора данных» и добавляем новое устройство:

Нажимаем добавить, затем три точечки в поле:

7. Нажимаем «Действия» - «Добавить»

8. Нажимаем «…»

9. Нажимаем «Действия», «Добавить» выбираем файл из папки с обработкой.

10. Нажимаем «Записать», затем «ОК»

11. Выбираем «Вид торгового оборудования» из списка («БИТ АБ: Терминалы сбора данных»):

12. Выбираем нужный терминал из списка, нажимаем «Записать», «Ок»:

В пункте настройки необходимо выставить следующие параметры:

Casio DT-930, x11: Для ИК и USB подставки – тип связи IRDA, таймаут 30, остальное по умолчанию.

Для BLUETOOTH – номер порта – тот, который выдал драйвер Bluetooth, Защищенный режим оставить включенным (для 930), таймаут 30.

Casio X-7, IT-600: Для ИК – тип связи IRDA, таймаут 30, остальное по умолчанию.

Для USB подставки тип связи NET, порт 2000, таймаут 30

Для BLUETOOTH – номер порта – тот, который выдал драйвер Bluetooth, Защищенный режим выключен, таймаут 30.

13. Проверяем тестом – На терминале заходим в «установки», «общие», «режим сервера» - ставим плюсик. Выходим в главное меню – сохраняемся.

Нажимаем тест в окошке настройки параметров. Затем «обмен данных» в терминале.

14. Заходим в «Сервис», «Торговое оборудование», «Работа с Терминалом», «форматы»

15. настраиваем форматы загрузки и выгрузки:


FAQ

Navigation: »No topics above this level«

FAQ

 Return to chapter overview